Вопрос задан 13.01.2019 в 17:33.
Предмет Информатика.
Спрашивает Гиниятуллина Карина.
Написать программу для нахождения а) НОД, б) НОК двух натуральных чисел а, b.
Ответы на вопрос
Отвечает Сомойленко Руслана.
Program gt1;
var m,n,q,r,t:longint;
begin
read(m,n);
t:=m*n;
r:=1;
while r<>0 do
begin
q:=m div n;
r:=m mod n;
if (r<>0)then begin
m:=n;
n:=r;
end;
end;
t:=t div n;
write(n,' ',t);
end.
t-НОК
n-получившиеся НОД
var m,n,q,r,t:longint;
begin
read(m,n);
t:=m*n;
r:=1;
while r<>0 do
begin
q:=m div n;
r:=m mod n;
if (r<>0)then begin
m:=n;
n:=r;
end;
end;
t:=t div n;
write(n,' ',t);
end.
t-НОК
n-получившиеся НОД
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
