Вопрос задан 30.12.2018 в 04:26.
Предмет Информатика.
Спрашивает Сундеева Аня.
Помогите составить программу

Ответы на вопрос
Отвечает Воробьева Кира.
Const e=0.0004;
var x,a,f,y:real; n,z:integer;
begin
x:=2.65; a:=1.5;
f:=1/(2*a);
n:=1; z:=1;
y:=a*cos(n*x)/(a*a-n*n);
while abs(y)>e do begin
f:=f+y;
n:=n+1;
z:=-z;
y:=z*a*cos(n*x)/(a*a-n*n);
end;
writeln('F(',x,') = ',f:8:5);
end.
Пример:
F(2.65) = -0.37856
var x,a,f,y:real; n,z:integer;
begin
x:=2.65; a:=1.5;
f:=1/(2*a);
n:=1; z:=1;
y:=a*cos(n*x)/(a*a-n*n);
while abs(y)>e do begin
f:=f+y;
n:=n+1;
z:=-z;
y:=z*a*cos(n*x)/(a*a-n*n);
end;
writeln('F(',x,') = ',f:8:5);
end.
Пример:
F(2.65) = -0.37856
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
