Вопрос задан 27.12.2018 в 06:33.
Предмет Информатика.
Спрашивает Мишурин Стефан.
Язык C#. Написать программу на языке C#разветвляющейся структуры согласно вариантам задания 1
(используя if) и задания 2 (используя switch) . 1.Даны два числа. Большее из этих двух чисел заменить их полусуммой, а меньшее удвоенным произведением. 2.2. Вводится число экзаменов N<=20. Напечатать фразу "Мы успешно сдали N экзаменов", согласовав слово "экзамен" с числом N.Ответы на вопрос
Отвечает Samarhan Eldos.
1.
using System;
class Program
{
public static void Main()
{
double x,y,s,p;
Console.Write("x = ");
x = double.Parse(Console.ReadLine());
Console.Write("y = ");
y = double.Parse(Console.ReadLine());
s = (x+y)/2;
p = 2*x*y;
if (x>y){
x = p;
y = s;
}
else {
y = p;
x = s;
}
Console.WriteLine("x = {0}, y = {1}", x, y);
Console.ReadKey();
}
}
Пример:
x = 2.4
y = 8.3
x = 5.35, y = 39.84
2.
using System;
public class Test
{
public static void Main()
{
int n;
Console.Write("n = ");
n = int.Parse(Console.ReadLine());
switch (n){
case 1:
Console.WriteLine("Мы успешно сдали {0} экзамен", n);
break;
case 2:
case 3:
case 4:
Console.WriteLine("Мы успешно сдали {0} экзамена", n);
break;
default:
Console.WriteLine("Мы успешно сдали {0} экзаменов", n);
break;
}
}
}
Пример:
n = 6
Мы успешно сдали 6 экзаменов
using System;
class Program
{
public static void Main()
{
double x,y,s,p;
Console.Write("x = ");
x = double.Parse(Console.ReadLine());
Console.Write("y = ");
y = double.Parse(Console.ReadLine());
s = (x+y)/2;
p = 2*x*y;
if (x>y){
x = p;
y = s;
}
else {
y = p;
x = s;
}
Console.WriteLine("x = {0}, y = {1}", x, y);
Console.ReadKey();
}
}
Пример:
x = 2.4
y = 8.3
x = 5.35, y = 39.84
2.
using System;
public class Test
{
public static void Main()
{
int n;
Console.Write("n = ");
n = int.Parse(Console.ReadLine());
switch (n){
case 1:
Console.WriteLine("Мы успешно сдали {0} экзамен", n);
break;
case 2:
case 3:
case 4:
Console.WriteLine("Мы успешно сдали {0} экзамена", n);
break;
default:
Console.WriteLine("Мы успешно сдали {0} экзаменов", n);
break;
}
}
}
Пример:
n = 6
Мы успешно сдали 6 экзаменов
Топ вопросов за вчера в категории Информатика
Информатика 20
Информатика 23
Информатика 22
Информатика 29
Информатика 21
Информатика 20
Информатика 26
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
