Вопрос задан 18.11.2018 в 07:46.
Предмет Информатика.
Спрашивает Жанабай Куаныш.
Паскаль. Написать программу вычисления произведения n чисел то есть 1*2*3*...*n,причем, если n=0,
то произведение равно 1.Число множителей не должно превышать 33.При вводе числа более 33, сообщить об ошибке и повторить ввод.Ответы на вопрос
Отвечает Хомчик Ксения.
программа не будет давать верный ответ при n>20 т.к. нет такого целочисленного типа переменных. uint64-самый большой из всех
var
i, n, p: uint64;
a: array [1..10000] of integer;
begin
read(n);
p:=1;
for i:=1 to n do
begin
a[i]:=i;
p:=p*a[i];
end;
if n>33 then
writeln('eror')
else
if n=0 then
writeln('p=1')
else
writeln('p=',p);
end.
Топ вопросов за вчера в категории Информатика
Информатика 33
Информатика 32
Информатика 51
Информатика 95
Информатика 36
Информатика 23
Информатика 36
Информатика 12
Информатика 14
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
