Вопрос задан 15.11.2018 в 14:00. Предмет Информатика. Спрашивает Чистякова Варя.

Помогите составить программу...вот она. Даны К и массив Т(к). Найти сумму и количество элементов в

массиве Т после первого нулевого элемента.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Жанбырбек Шугыла.
Const kmax = 20;
var T:array [1..kmax] of integer;
     i,k,zero,sum,count:integer;
begin
  count:=0;
  sum:=0;
  repeat
   write ('K(K<20) = ');
   readln (k);
  until k in [1..kmax];
  randomize;
  for i:=1 to k do
   begin
    T[i]:=random(14)-5;
    write (T[i]:3);
   end;
  writeln;
  zero:=1;
  while (zero<=k) and (T[zero]<>0) do inc(zero);
  count:=k-zero;
  if zero<>kmax then 
    for i:=zero+1 to k do sum:=sum+T[i];
  writeln ('Summa: ',sum);
  writeln ('Kol-vo: ',count);
end.
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос