Вопрос задан 07.11.2018 в 18:58.
Предмет Информатика.
Спрашивает Бродский Иосиф.
Помогите Написать программу на языке С#, которая по введенному значению аргумента вычисляет
значение функции, заданной в виде графика. Параметр R вводится с клавиатуры. Заранее огромное спасибо.
Ответы на вопрос
Отвечает Спартак Кирилл.
Using System;
public class Test
{
public static void Main()
{
double r, x, y;
Console.WriteLine("r = ");
r = double.Parse(Console.ReadLine());
Console.WriteLine("x = ");
x = double.Parse(Console.ReadLine());
if (x<=0) y = -0.5*x;
else if (x<=r) y = -Math.Sqrt(4-x*x)+2;
else if (x<=2*r) y = Math.Sqrt(4-(x-2)*(x-2));
else y = -x+2*r;
Console.WriteLine("y = " + y);
Console.ReadLine();
}
}
Пример:
r = 2
x = 3
y = 1.73205080756888
public class Test
{
public static void Main()
{
double r, x, y;
Console.WriteLine("r = ");
r = double.Parse(Console.ReadLine());
Console.WriteLine("x = ");
x = double.Parse(Console.ReadLine());
if (x<=0) y = -0.5*x;
else if (x<=r) y = -Math.Sqrt(4-x*x)+2;
else if (x<=2*r) y = Math.Sqrt(4-(x-2)*(x-2));
else y = -x+2*r;
Console.WriteLine("y = " + y);
Console.ReadLine();
}
}
Пример:
r = 2
x = 3
y = 1.73205080756888
Топ вопросов за вчера в категории Информатика
Информатика 437
Информатика 11
Информатика 10
Информатика 44
Информатика 23
Информатика 43
Информатика 63
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
