Вопрос задан 28.10.2018 в 13:28. Предмет Информатика. Спрашивает Самсонова Виктория.

Кто смыслит в ИНФЕ ПОМОГИТЕ!!! Написать программу, позволяющею по последней цифре числа определить

последнюю цифру его квадрата. _______________________________________________ Вот примерно я написал, а дальше не могу!!! uses crt; var a,b: integer; begin writeln('Bведите a'); readln(a); case b of ....... Допишите та буквально 2-3 строки еще без end...
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Шапули Наталья.
Uses crt;
var a,b: integer;
begin
writeln('Bведите a');
readln(a);
b := a mod 10;
b := b * b;
b := b mod 10;
write('Последняя цифра квадрата: ');
writeln(b);
end.

Вариант с CASE:
uses crt;
var a,b: integer;
begin
writeln('Bведите a');
readln(a);
b := a mod 10;
write('Последняя цифра квадрата: ');
case b of
0: writeln(0);
1: writeln(1);
2: writeln(4);
3: writeln(9);
4: writeln(6);
5: writeln(5);
6: writeln(6);
7: writeln(9);
8: writeln(4);
9: writeln(1);
end;
end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Да, конечно, я помогу вам завершить программу. Для определения последней цифры квадрата числа можно воспользоваться свойством остатка от деления на 10. Вот как это можно сделать:

```pascal uses crt; var a, b: integer;

begin writeln('Введите число a'); readln(a);

// Вычисляем квадрат числа a b := a * a;

// Определяем последнюю цифру квадрата b := b mod 10;

writeln('Последняя цифра квадрата числа ', a, ' равна ', b); end. ```

В данной программе после вычисления квадрата числа `a`, остаток от деления на 10 присваивается переменной `b`, что и позволяет определить последнюю цифру квадрата числа `a`.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос