Вопрос задан 13.10.2018 в 11:12.
Предмет Информатика.
Спрашивает Мирошниченко Женя.
Помогите пожалуйста написать программу (паскаль) 10 класс дам 20 баллов

Ответы на вопрос
Отвечает Шубина Татьяна.
Program pr;
uses crt;
Var n,i, k1,k2:integer;
mas: array[1..1000] of integer;
Begin
randomize;
Writeln('Введите размер массива не больше 1000');
readln(n);
k1:=0;
k2:=0;
for i:=1 to n do
Begin
mas[i]:=Random(220+1)-70;
if (mas[i]<0)
then k1:=k1+1;
if (mas[i]>0)
then k2:=k2+1;
end;
Writeln('Сформированный массив:');
for i:=1 to n do
Begin
Write(mas[i],' ');
end;
Writeln();
Writeln('Количество отрицательных = ', k1);
Writeln('Количество положительных = ', k2);
readln;
end.
uses crt;
Var n,i, k1,k2:integer;
mas: array[1..1000] of integer;
Begin
randomize;
Writeln('Введите размер массива не больше 1000');
readln(n);
k1:=0;
k2:=0;
for i:=1 to n do
Begin
mas[i]:=Random(220+1)-70;
if (mas[i]<0)
then k1:=k1+1;
if (mas[i]>0)
then k2:=k2+1;
end;
Writeln('Сформированный массив:');
for i:=1 to n do
Begin
Write(mas[i],' ');
end;
Writeln();
Writeln('Количество отрицательных = ', k1);
Writeln('Количество положительных = ', k2);
readln;
end.
Топ вопросов за вчера в категории Информатика
Информатика 17
Информатика 40
Информатика 27
Информатика 61
Информатика 10
Информатика 13
Информатика 42
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
