
Помогите написать программу в Паскале. Дано трёхзначное число N. Определить, какая из его цифр
больше - первая или вторая. Если цифры одинаковы, то выдать об этом сообщение.

Ответы на вопрос

a,b:integer;
Begin
Write('Введите трёхзначное число: ');
ReadLn(a);
b:=(a div 10) mod 10;
a:=a div 100;
if a > b then Write('Первая цифра больше')
else if a < b then Write('Вторая цифра больше')
else Write('Первые две цифры равны')
End.



Конечно, вот пример программы на Pascal, которая решает вашу задачу:
```pascal program CompareDigits;
var N, firstDigit, secondDigit, thirdDigit: integer;
begin // Ввод трехзначного числа writeln('Введите трехзначное число N:'); readln(N);
// Проверка на трехзначность числа if (N < 100) or (N > 999) then begin writeln('Число не является трехзначным.'); exit; end;
// Выделение цифр thirdDigit := N mod 10; N := N div 10; secondDigit := N mod 10; firstDigit := N div 10;
// Сравнение цифр и вывод результата if firstDigit > secondDigit then writeln('Первая цифра больше второй.') else if secondDigit > firstDigit then writeln('Вторая цифра больше первой.') else writeln('Первая и вторая цифры равны.');
end. ```
Эта программа запрашивает трехзначное число от пользователя, затем определяет его цифры и сравнивает первую и вторую цифры, выводя соответствующее сообщение.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili