ПОЖАЛУЙСТА помогите!!!!!! Составить программу в паскаль Опрашивается 10 человек. Сколько человек
любят мороженое? Сделать с помощью оператора циклаОтветы на вопрос
// Внимание! Если программа не работает, обновите версию!
// 1 - любит мороженое, 0 - не любит.
begin
var a:= ArrRandom(10, 0,1);a.Println;
var cnt := 0;
for var i:= 0 to 9 do
if a[i] = 1 then inc(cnt);
Writeln(cnt);
end.
Пример:
1 1 1 0 0 0 0 1 1 1
6
Для решения данной задачи вам потребуется использовать оператор цикла в программе на языке Pascal. Вот пример программы, которая опрашивает 10 человек и подсчитывает, сколько из них любят мороженое:
```pascal program CountIceCreamLovers;
var i, count: integer; answer: char;
begin count := 0; // инициализируем счетчик
for i := 1 to 10 do begin writeln('Человек ', i, ': Любите ли вы мороженое? (Y/N)'); readln(answer);
if (answer = 'Y') or (answer = 'y') then count := count + 1; // увеличиваем счетчик, если ответ положительный end;
writeln('Количество людей, которые любят мороженое: ', count); end. ```
В этой программе мы используем переменные `i` и `count`. Переменная `i` используется для отслеживания номера человека, а переменная `count` - для подсчета количества людей, которые любят мороженое.
Оператор цикла `for` выполняется 10 раз, так как мы хотим опросить 10 человек. Внутри цикла мы задаем вопрос каждому человеку и считываем его ответ с помощью `readln`. Если ответ положительный (Y или y), то мы увеличиваем значение счетчика `count` на 1.
После завершения цикла мы выводим количество людей, которые любят мороженое, с помощью `writeln`.
Примечание: Программа предполагает, что пользователь будет вводить только символы 'Y' или 'N' (или их нижний регистр). Если пользователь вводит что-то отличное от этого, программа может работать некорректно.
Надеюсь, это поможет вам решить вашу задачу! Если у вас возникнут еще вопросы, не стесняйтесь задавать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
