Вопрос задан 14.09.2018 в 04:40. Предмет Информатика. Спрашивает Левкин Даня.

Ребят помогите, легкая программа.Составить программу на Турбо Паскале: Дана строка. Сформировать

новую строку из 2-й, 3-й, 4-й и последней букв.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Карпенко София.
Var s1,s2:string;
begin
writeln('Введите строку:');
readln(s1);
s2:=s1[2]+s1[3]+s1[4]+s1[length(s1)];
writeln(s2);
end.

Пример:
Введите строку:
программа
рога
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Составление программы на Turbo Pascal для формирования новой строки

Для составления программы на Turbo Pascal, которая будет формировать новую строку из 2-й, 3-й, 4-й и последней букв исходной строки, можно использовать следующий код:

```pascal program FormNewString; var originalString, newString: string; begin writeln('Введите исходную строку:'); readln(originalString); // Проверка, что исходная строка содержит не менее 4 символов if length(originalString) >= 4 then begin // Формирование новой строки newString := originalString[2] + originalString[3] + originalString[4] + originalString[length(originalString)]; // Вывод новой строки writeln('Новая строка:', newString); end else begin writeln('Исходная строка должна содержать не менее 4 символов.'); end; readln; end. ```

Эта программа запрашивает у пользователя исходную строку, затем проверяет, что она содержит не менее 4 символов. Если это условие выполняется, программа формирует новую строку, состоящую из 2-й, 3-й, 4-й и последней букв исходной строки. Затем программа выводит новую строку на экран.

Примечание: Убедитесь, что у вас установлена среда разработки Turbo Pascal и что код скомпилирован и запущен в этой среде для правильного выполнения программы.

Надеюсь, это поможет вам составить программу на Turbo Pascal для формирования новой строки из указанных символов. Если у вас возникнут дополнительные вопросы, пожалуйста, не стесняйтесь задавать их!

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос