
Pascal, цикл для, составить программу Ввести целое число N. Найти сумму первых N чётных натуральных
чисел.

Ответы на вопрос

begin
write('n = ');
readln(n);
s:=0;
for i:=1 to n do s:=s+2*i;
writeln('s = ',s);
end.
Пример:
n = 5
s = 30



Программа на языке Pascal, которая находит сумму первых N четных натуральных чисел, может быть следующей:
```pascal program SumOfEvenNumbers;
var N, i, sum: integer;
begin writeln('Введите целое число N:'); readln(N);
sum := 0; i := 1;
while N > 0 do begin if i mod 2 = 0 then begin sum := sum + i; N := N - 1; end; i := i + 1; end;
writeln('Сумма первых ', N, ' четных натуральных чисел:', sum); end. ```
Давайте разберем эту программу по шагам:
1. Объявляем переменные `N`, `i` и `sum`. Переменная `N` будет хранить количество четных чисел, `i` - текущее число, а `sum` - сумму четных чисел. 2. Вводим значение `N` с помощью `readln`. 3. Инициализируем переменные `sum` и `i` нулевыми значениями. 4. Запускаем цикл `while` до тех пор, пока `N` больше нуля. 5. Внутри цикла проверяем, является ли текущее число `i` четным с помощью оператора `mod`. Если остаток от деления `i` на 2 равен нулю, то число `i` четное. 6. Если число `i` четное, то добавляем его к сумме `sum` и уменьшаем значение `N` на единицу. 7. Увеличиваем значение `i` на единицу для перехода к следующему числу. 8. По завершении цикла выводим результат - сумму четных чисел.
Например, если мы введем значение `N = 5`, программа найдет сумму первых пяти четных чисел (2 + 4 + 6 + 8 + 10) и выведет результат: "Сумма первых 5 четных натуральных чисел: 30".


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili