даны 2 вещественных числа. Напишите программу которая уменьшает первое число в 5 раз если она
больше второгоОтветы на вопрос
Program z1;
var a,b:integer;
begin
writeln('ведите числа-э);
readln(a,b);
if a>b then
begin
a:=a-1;
end;
writeln('a=',a);
end. усё....
Я могу помочь вам с написанием программы, которая уменьшает первое число в 5 раз, если оно больше второго. Вот пример такой программы на языке Python:
```python # Даны два вещественных числа a = float(input("Введите первое число: ")) # Считываем первое число с клавиатуры b = float(input("Введите второе число: ")) # Считываем второе число с клавиатуры
# Если первое число больше второго, то уменьшаем его в 5 раз if a > b: a = a / 5 # Делим первое число на 5
# Выводим результат на экран print("Первое число:", a) print("Второе число:", b) ```
Эта программа считывает два вещественных числа с клавиатуры, сравнивает их и, если первое число больше второго, то уменьшает его в 5 раз. Затем программа выводит оба числа на экран. Например, если мы введем 10 и 2, то программа выведет:
``` Первое число: 2.0 Второе число: 2.0 ```
Надеюсь, это поможет вам понять, как написать такую программу. Если у вас есть еще вопросы, я буду рад ответить на них.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
