Вопрос задан 02.09.2018 в 03:33. Предмет Информатика. Спрашивает Юшкевич Егор.

Составьте программу на Паскале вывести на экран элементы одномерного массивного формированного из

Квадратов чисел натурального ряда 1 ,2,3,...10,.. .
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Сафронов Кирилл.
Var i, t:integer;
l:array[1..100000000] of longint;
begin
writeln ('Введите до какого числа вычислять квадрат');
readln (t);
For i:=1 to t do
begin
l[i]:=sqr(i);
write (l[i], ' ');
end;
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот программа на языке Pascal, которая выводит квадраты чисел натурального ряда до определенного предела:

```pascal program Квадраты_чисел;

const Предел = 10; // Максимальное число, до которого нужно вывести квадраты

var Массив: array[1..Предел] of Integer; i: Integer;

begin // Заполняем массив квадратами чисел от 1 до Предела for i := 1 to Предел do Массив[i] := i * i;

// Выводим элементы массива на экран writeln('Квадраты чисел от 1 до ', Предел, ':'); for i := 1 to Предел do writeln('Квадрат ', i, ' = ', Массив[i]); end. ```

Эта программа создает массив `Массив`, где каждый элемент массива равен квадрату своего индекса. После этого она выводит на экран квадраты чисел от 1 до определенного предела (в данном случае, до 10).

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос