Написать программу Вычислить сумму двух последних цифр двух натуральных трехзначных чисел.
Ответы на вопрос
a,b,s:integer;
begin
Write('Введите два натуральных трехзначных числа: ');
Read(a,b);
s:=a mod 10 + (a mod 100) div 10;
s:=s+b mod 10 + (b mod 100) div 10;
Writeln('Сумма двух последних цифр чисел равна ',s)
end.
Пример
Введите два натуральных трехзначных числа: 132 559
Сумма двух последних цифр чисел равна 19
Для вычисления суммы двух последних цифр двух натуральных трехзначных чисел можно написать программу на языке Python. Вот пример такой программы:
```python # Ввод двух трехзначных чисел num1 = int(input("Введите первое трехзначное число: ")) num2 = int(input("Введите второе трехзначное число: "))
# Вычисление суммы двух последних цифр sum_digits = (num1 % 100) + (num2 % 100)
# Вывод результата print("Сумма двух последних цифр двух чисел:", sum_digits) ```
При запуске программы она будет запрашивать у пользователя два трехзначных числа и затем вычислять сумму двух последних цифр этих чисел. Результат будет выведен на экран.
Например, если пользователь введет первое число 456 и второе число 789, программа выведет на экран: "Сумма двух последних цифр двух чисел: 35".
Обратите внимание, что в данном примере предполагается, что пользователь будет вводить только трехзначные числа. Если пользователь введет число, не соответствующее этому условию, программа может дать некорректный результат.
Источник:
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
