Составьте программу ввода элементов массива a[1..15] с клавиатуры и вывода на экран элементов со
значениями кратными 5Ответы на вопрос
const
KR = 5;
SIZE = 15;
var
a: array[1..SIZE] of integer;
i: integer;
begin
for i := 1 to SIZE do
begin
write('a[',i,']=');
readln(a[i]);
if a[i] mod KR = 0 then
writeln('a[',i,'] кратное ',KR);
end;
end.
Программа ввода элементов массива и вывода элементов с кратными 5 значениями
Вот пример программы на языке программирования C++, которая позволяет пользователю ввести элементы массива `a[1..15]` с клавиатуры и выводит на экран только те элементы, которые кратны 5:
```cpp
#include
int main() { int a[15];
std::cout << "Введите элементы массива a[1..15]:\n"; for (int i = 0; i < 15; i++) { std::cout << "a[" << i + 1 << "] = "; std::cin >> a[i]; }
std::cout << "Элементы массива, кратные 5:\n"; for (int i = 0; i < 15; i++) { if (a[i] % 5 == 0) { std::cout << a[i] << " "; } }
return 0; } ```
Эта программа создает массив `a` размером 15 элементов и запрашивает у пользователя ввод значений для каждого элемента. Затем она выводит только те элементы массива, которые кратны 5.
Примечание: Программа написана на языке C++, но вы можете использовать аналогичный подход на других языках программирования, таких как Java, Python или JavaScript.
Надеюсь, это поможет! Если у вас возникнут еще вопросы, не стесняйтесь задавать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
