Составить программу по задаче Запрашивается число, если оно нечетное, то прибавляется 11 и
выводится на экран".Ответы на вопрос
Ответ:
С++
#include <iostream>
using namespace std;
int main()
{
setlocale(LC_ALL, "RUS");
int a;
cout << "Введите число: ";
cin >> a;
if (a % 2 == 0)
{
cout << "Число " << a << " чётное"<< endl;
}
else
{
a = a + 11;
cout << "Число " << a << " нечётное" << endl;
}
}
Программа для проверки и вывода числа
Для решения задачи, где требуется проверить, является ли число нечетным, и если да, то прибавить 11 и вывести результат на экран, можно использовать следующую программу на языке программирования:
```python number = int(input("Введите число: ")) # Запрашиваем число у пользователя
if number % 2 != 0: # Проверяем, является ли число нечетным number += 11 # Прибавляем 11 к числу
print("Результат:", number) # Выводим результат на экран ```
В этой программе мы сначала запрашиваем число у пользователя с помощью функции `input()`. Затем мы проверяем, является ли число нечетным, с помощью оператора `%` (остаток от деления). Если остаток от деления числа на 2 не равен 0, то число является нечетным. В этом случае мы прибавляем 11 к числу с помощью оператора `+=`. Наконец, мы выводим результат на экран с помощью функции `print()`.
Пример работы программы: ``` Введите число: 7 Результат: 18 ```
Примечание: В данном ответе использованы общие знания о программировании и логике работы с числами. Никакие конкретные источники не были использованы для составления этой программы.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
