5. Составьте программу сортировки по возрастанию значений в трех переменных: А, В, С. 6. Составьте
программу вычисления корней квадратного уравнения по данным значениям его коэффициентов. НЕ ИЗ ИНТЕРНЕТА!!Ответы на вопрос
A,B,C:integer;
Begin
WriteLn('Введите три числа');
ReadLn(A,B,C);
if (A<=B)and(B<=C) then Write(A,' ',B,' ',C)
else if (A<=C)and(C<=B) then Write(A,' ',C,' ',B)
else if (B<=A)and(A<=C) then Write(B,' ',A,' ',C)
else if (B<=C)and(C<=A) then Write(B,' ',C,' ',A)
else if (C<=A)and(A<=B) then Write(C,' ',A,' ',B)
else if (C<=B)and(B<=A) then Write(C,' ',B,' ',A)
End.
Var a,b,c,D:real;
Begin
Write('a = ');ReadLn(a);
Write('b = ');ReadLn(b);
Write('c = ');ReadLn(c);
D:=b*b-4*a*c;
if D>=0 then
Begin
WriteLn('x = ',(-b-sqrt(D))/(2*a));
WriteLn('x = ',(-b+sqrt(D))/(2*a));
End
else WriteLn('Действительных корней нет')
End.
5. Программа сортировки по возрастанию значений в трех переменных A, B, C:
``` # Ввод значений переменных A, B, C A = int(input("Введите значение переменной A: ")) B = int(input("Введите значение переменной B: ")) C = int(input("Введите значение переменной C: "))
# Сортировка значений переменных if A > B: A, B = B, A if B > C: B, C = C, B if A > B: A, B = B, A
# Вывод отсортированных значений переменных print("Отсортированные значения переменных:", A, B, C) ```
6. Программа вычисления корней квадратного уравнения по данным значениям его коэффициентов:
``` # Ввод значений коэффициентов квадратного уравнения a = float(input("Введите значение коэффициента a: ")) b = float(input("Введите значение коэффициента b: ")) c = float(input("Введите значение коэффициента c: "))
# Вычисление дискриминанта D = b**2 - 4*a*c
# Проверка наличия корней и их вычисление if D > 0: x1 = (-b + D**0.5) / (2*a) x2 = (-b - D**0.5) / (2*a) print("Уравнение имеет два корня:", x1, "и", x2) elif D == 0: x = -b / (2*a) print("Уравнение имеет один корень:", x) else: print("Уравнение не имеет действительных корней") ```
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
