Составить программу для игры «Коровы и быки». Программа выбирает случайным образом четырехзначное
число с разными цифрами. Нужно угадать это число. На каждом шаге играющий называет четырехзначное число, а программа сообщает, сколько цифр числа угадано (быки) и сколько угаданных цифр стоит на своем месте (коровы). Например, если было загадано число 1294, а играющий назвал 1423, он получит ответ «1 корова, 3 быка». скласти блок схему по паскалюОтветы на вопрос
Відповідь:тилятко
Пояснення:воны народжуються у быка та коровы
Вот пример программы на Pascal для игры "Коровы и быки":
``` program BullsAndCows;
uses crt;
var secretNumber, guessNumber: String; bulls, cows: Integer; i, j: Integer; digitFound: Boolean;
begin clrscr; // Выбираем случайное четырехзначное число с разными цифрами randomize; repeat secretNumber := ''; for i := 1 to 4 do begin digitFound := false; while not digitFound do begin j := random(10); str(j, guessNumber); if pos(guessNumber, secretNumber) = 0 then begin secretNumber := secretNumber + guessNumber; digitFound := true; end; end; end; until length(secretNumber) = 4; // Начинаем игру repeat bulls := 0; cows := 0; // Игрок вводит свое предположение write('Введите четырехзначное число: '); readln(guessNumber); // Проверяем количество угаданных быков for i := 1 to 4 do begin if guessNumber[i] = secretNumber[i] then bulls := bulls + 1; end; // Проверяем количество угаданных коров for i := 1 to 4 do begin for j := 1 to 4 do begin if (i <> j) and (guessNumber[i] = secretNumber[j]) then cows := cows + 1; end; end; // Выводим результат writeln(bulls, ' корова, ', cows, ' бык'); // Проверяем, угадал ли игрок число if bulls = 4 then begin writeln('Поздравляем! Вы угадали число!'); break; end; until false; readln; end. ```
Эта программа выбирает случайное четырехзначное число с разными цифрами и просит игрока угадать его. После каждой попытки игрока программа сообщает количество угаданных быков (цифры, стоящие на своих местах) и коров (угаданные цифры, но не на своем месте). Игра продолжается до тех пор, пока игрок не угадает число.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
