Вопрос задан 16.11.2023 в 21:55. Предмет Информатика. Спрашивает Юпатова Лера.

(python) Дома напишите программу " Логин Пароль с помощью цикла while , чтобы у пользователя было 2

попып на ввод логина пароли , если ползоватем будет вводить их неверно и далее если он привысит 2 попытки , то покинет программу с помощью ключевого слова break​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Матков Роман.

Ответ:

password = 333 #Переменная password со значением 333 - это пароль

user_enter = int(input('Введите пароль: ')) #Здесь пользователь должен ввести пароль

while user_enter:

   if user_enter == password: #Если ведёный пароль равен 333,

       print('Доступ разрешён') #то вывести на экран Доступ разрешён,

       break #и завершить программу

   elif user_enter != password: #Если пароль не равен 333

       print('Неверный пароль. Повторите попытку')

       for i in range (1):

           user_enter = int(input('Введите пароль: '))

       break

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Python, реализующей заданное:

```python # Инициализация переменных с правильными логином и паролем правильный_логин = "user" правильный_пароль = "password"

# Инициализация счетчика попыток попытки = 0

# Начало бесконечного цикла while while True: # Запрос ввода логина и пароля у пользователя введенный_логин = input("Введите логин: ") введенный_пароль = input("Введите пароль: ")

# Проверка введенных данных if введенный_логин == правильный_логин and введенный_пароль == правильный_пароль: print("Вход выполнен успешно!") break # Выход из цикла при успешном вводе

# Вывод сообщения об ошибке и увеличение счетчика попыток print("Неверный логин или пароль. Попробуйте еще раз.") попытки += 1

# Проверка на превышение лимита попыток (2 попытки) if попытки >= 2: print("Превышено количество попыток. Доступ запрещен.") break # Выход из цикла при превышении лимита попыток ```

Этот код запрашивает у пользователя логин и пароль в цикле while. Если введенные данные правильные, программа завершает выполнение. Если введенные данные неверные, программа выводит сообщение об ошибке и увеличивает счетчик попыток. Если количество попыток превышает 2, программа завершает выполнение с помощью ключевого слова `break`.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос