Вопрос задан 25.06.2023 в 01:46. Предмет Информатика. Спрашивает Ростовская Полина.

8 класс. Питон. Задача1. Строковый метод isdigit() проверяет, состоит ли строка только из цифр.

Напишите программу, которая запрашивает ввод двух целых чисел и выводит их сумму. В случае некорректного ввода программа не должна завершаться с ошибкой, а должна продолжать запрашивать числа. Задача 2. Напишите шаблон по запросу у пользователя логина и пароля. Если логин или пароль будут введены с ошибкой, то необходимо вывести сообщение о том, что такой логин или пароль не найдены. Если логин и пароль совпадают, то вывести приветствие с указанием имени пользователя.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Андреянов Костя.

1)

x,y = map(str,input().split())

while not (x.isdigit() and y.isdigit()):

   x,y = map(str,input().split())

print(int(x)+int(y))

2)

Correct_login = "maxum000"

Correct_passw = "12345"

while (True):

   login = input("Логин: ")

   passw = input("Пароль: ")

   if (login == Correct_login and passw == Correct_passw):

       print("Добро пожаловать,", login)

       break

   elif (login != Correct_login):

       print("Такого пользователя и пароля не существует.")

   elif (login == Correct_login and passw != Correct_passw):

       print("Неверный пароль, попробуйте снова.")

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения задачи 1, вы можете использовать цикл while для запроса ввода чисел и проверки их корректности с помощью метода isdigit(). Если пользователь вводит некорректные данные (не цифры), программа будет продолжать запрашивать числа до тех пор, пока не будут введены корректные данные. Затем программа выведет сумму введенных чисел.

python
while True: num1 = input("Введите первое целое число: ") num2 = input("Введите второе целое число: ") if num1.isdigit() and num2.isdigit(): num1 = int(num1) num2 = int(num2) result = num1 + num2 print(f"Сумма чисел: {result}") break else: print("Некорректный ввод. Пожалуйста, введите целые числа.")

Для задачи 2, вы можете использовать словарь для хранения пар логинов и паролей. Затем программа будет запрашивать у пользователя логин и пароль, проверять их соответствие данным из словаря и выводить соответствующее сообщение.

python
# Создаем словарь с парами логинов и паролей user_credentials = {"user1": "password1", "user2": "password2"} while True: login = input("Введите логин: ") password = input("Введите пароль: ") if login in user_credentials and user_credentials[login] == password: print(f"Привет, {login}!") break else: print("Логин или пароль не найдены. Пожалуйста, повторите попытку.")

Обратите внимание, что в реальных приложениях пароли хранятся в зашифрованном виде, а не в открытом тексте, для обеспечения безопасности.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос