Вопрос задан 16.11.2023 в 12:21. Предмет Информатика. Спрашивает Маринець Макс.

Написать программу Паскаль Известно, что среди двузначных чисел есть те, у которых сумма цифр не

превосходит 27. Найдите эти числа.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Герасименко Катя.

var

 n, a, i, cnt: Integer;

 

begin

   cnt := 0;

   Write('Введите кол-во чисел: ');

   Read(n);

   Write('Введите двузначные числа: ');

   

   for i := 1 to n do begin

       Read(a);

       if a mod 10 + a div 10 <= 27 then

           Inc(cnt)

   end;

   

   Write('Кол-во чисел, сумма цифр которых не превышает 27: ', cnt)

end.  

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения данной задачи воспользуемся программированием на языке Pascal. Ниже приведен код, который найдет все двузначные числа, у которых сумма цифр не превосходит 27:

```pascal program FindNumbers;

var num, digit1, digit2, sum: integer;

begin // Перебираем все двузначные числа for num := 10 to 99 do begin // Вычисляем первую и вторую цифры числа digit1 := num div 10; digit2 := num mod 10; // Суммируем цифры числа sum := digit1 + digit2; // Проверяем, не превосходит ли сумма цифр значение 27 if sum <= 27 then begin // Выводим числа, удовлетворяющие условию writeln(num); end; end; end. ```

После запуска программы, на экране будут выведены все двузначные числа, у которых сумма цифр не превосходит 27.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос