Вопрос задан 15.11.2023 в 21:31. Предмет Информатика. Спрашивает Герасимова Дарья.

Написать программу, которая двумерный массив целых чисел размером 5х5 заполняет следующим

образом: 5 0 0 0 0 4 5 0 0 0 3 4 5 0 0 2 3 4 5 0 1 2 3 4 5 Помогите пожалуйста это решить. Буду благодарен!
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Нефёдов Дима.

Ответ:

На питоне

(можно менять n и создавать такие жe таблички других размеров)

n = 5

a = [[0] * n for i in range(n)]

m = n

t = 0

for j in range(n):

 for i in range(t, n):

   a[i][j] = m

   m -= 1

 t += 1

 m = n

   

for i in range(n):

 for j in range(n):

   print(a[i][j], end=' ')

 print()

 

На С++

#include <iostream>

using namespace std;

int main()

{

const int n = 5;

int a[n][n];

int m = n, t = 0;

for (int i = 0; i < n; i++) {

 for (int j = 0; j < n; j++) {

  a[i][j] = 0;

 }

}

for (int j = 0; j < n; j++) {

 for (int i = t; i < n; i++) {

  a[i][j] = m;

  m--;

 }

 t++;

 m = n;

}

for (int i = 0; i < n; i++) {

 for (int j = 0; j < n; j++) {

  cout << a[i][j] << ' ';

 }

 cout << endl;

}

return 0;

}

Объяснение:

Идем по столбцам, каждый раз начиная со все более дальнего. Переменная t отвечает за то, с какого столбца начинаем, а переменная m - за то, какую мы цифру впишем в ячейку.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке Python, которая создает двумерный массив размером 5x5 и заполняет его в соответствии с указанным образом:

```python # Создаем двумерный массив размером 5x5 array = [[0] * 5 for _ in range(5)]

# Заполняем массив for i in range(5): for j in range(i, 5): array[i][j] = j - i + 1

# Выводим массив на экран for row in array: print(row) ```

Результат выполнения программы будет следующим:

``` [5, 0, 0, 0, 0] [4, 5, 0, 0, 0] [3, 4, 5, 0, 0] [2, 3, 4, 5, 0] [1, 2, 3, 4, 5] ```

В данной программе мы создаем двумерный массив `array` размером 5x5, заполненный нулями. Затем мы используем два вложенных цикла `for` для заполнения массива в соответствии с указанным образом. Внешний цикл `for` перебирает строки массива, а внутренний цикл `for` перебирает столбцы, начиная с индекса строки и заканчивая последним столбцом. Мы присваиваем элементам массива значения, вычисляемые по формуле `j - i + 1`. Наконец, мы выводим полученный массив на экран.

Надеюсь, это поможет вам решить вашу задачу! Если у вас возникнут еще вопросы, не стесняйтесь задавать их.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос