Вопрос задан 15.11.2023 в 18:57. Предмет Информатика. Спрашивает Кузнецов Ваня.

ПАЙТОН 50 БАЛЛОВ!! Напишите программу для решения следующей задачи. Камера наблюдения регистрирует

в автоматическом режиме скорость проезжающих мимо неё автомобилей, округляя значения скорости до целых чисел. Необходимо определить среднюю зарегистрированную скорость всех автомобилей. Если скорость хотя бы одного автомобиля была не меньше 60 км/ч, выведите «YES», иначе выведите «NO». Программа получает на вход число проехавших автомобилей N (1 ≤ N ≤ 30), затем указываются их скорости. Значение скорости не может быть меньше 1 и больше 300. Программа должна сначала вывести среднюю скорость с точностью до одного знака после запятой, затем «YES» или «NO».
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Хараб Ярослав.

Программа:
Python:

N, summ, speed60 = int(input()), 0, False

for i in range(N):

   speed = int(input())

   if speed < 1 or speed > 300:

       print('Скорость не может быть меньше 1 и больше 300')

       continue

   else:

       summ += speed

   if speed >= 60 and not speed60: speed60 = True

print(round(summ/N, 1))

print('YES' if speed60 else 'NO')

Объяснение:

В начале вводится целое число N с клавиатуры, а также регистрируется переменняа summ, которой присваивается значение 0, переменная speed60 со значением False. Повторяем тело цикла N раз (с помощью цикла for): вводится скорость с клавиатуры. По условию скорось не может быть меньше 1 и больше 300 - делаем проверку. Если скорость действительно за рамками допустимых значений, выводим предупреждение и не учитываем это значение в сумму скоростей. Если скорость от 1 до 300, то к значению переменной summ прибавляем значение скорости. Делаем проверку, скорость больше либо равно 60 км/ч или нет. Если да, и переменная speed60 на данный момент False, то присваиваем ей значение True. Цикл окончен. В конце выводим среднее значение, округлённое до десятых, в следующей строке выводим "YES" если была скорость, которая больше либо равно 60, иначе выводим "NO".

Результат:

10

102

106

102

062

58

276

27

3

5

6

74.7

YES

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения данной задачи вам потребуется написать программу на языке Python. В программе вы будете получать на вход число проехавших автомобилей N (1 ≤ N ≤ 30), а затем указывать их скорости. Значение скорости не может быть меньше 1 и больше 300.

Алгоритм решения:

1. Создайте переменную `total_speed` и установите ее значение равным 0. Эта переменная будет использоваться для хранения суммы скоростей всех автомобилей. 2. Создайте переменную `count` и установите ее значение равным 0. Эта переменная будет использоваться для подсчета количества автомобилей. 3. Используйте цикл `for` для получения скоростей каждого автомобиля. 4. Внутри цикла: - Считайте скорость автомобиля с помощью функции `input()`. - Преобразуйте считанное значение в целое число с помощью функции `int()`. - Прибавьте значение скорости к переменной `total_speed`. - Увеличьте значение переменной `count` на 1. 5. После завершения цикла вычислите среднюю скорость, разделив сумму скоростей (`total_speed`) на количество автомобилей (`count`). 6. Выведите среднюю скорость с точностью до одного знака после запятой, используя функцию `round()`. 7. Используйте условный оператор `if` для проверки, есть ли хотя бы один автомобиль со скоростью не меньше 60 км/ч. 8. Если такой автомобиль есть, выведите "YES". В противном случае выведите "NO".

Пример решения на языке Python:

```python N = int(input("Введите количество автомобилей: ")) total_speed = 0 count = 0

for _ in range(N): speed = int(input("Введите скорость автомобиля: ")) total_speed += speed count += 1

average_speed = round(total_speed / count, 1) print("Средняя скорость:", average_speed)

if average_speed >= 60: print("YES") else: print("NO") ```

Примечание: В приведенном примере предполагается, что пользователь будет вводить значения скоростей автомобилей вручную. Вы можете изменить эту часть кода, чтобы значения скоростей автоматически считывались из файла или другого источника данных.

Надеюсь, это поможет вам решить задачу! Если у вас возникнут еще вопросы, не стесняйтесь задавать.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос