Вопрос задан 15.11.2023 в 16:35. Предмет Информатика. Спрашивает Куликова Ульяна.

Срочно язык паскаль!!!!! Напишите программу которая в последовательно натуральных чисел

определяет количество чётных трёхзначных чисел программа получает на ввод натуральные числа количество введённых чисел не известно последовательность чисел заканчивается числом 0
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Никликина Анастасия.

var k,schet:integer;

begin

   schet:=0;

   k:=1;

   while k <> 0 do begin

     readln(k);

   if (k mod 2 = 0) and (k>99) and (k <= 999) then

     schet:=schet+1;

   end;

   writeln(schet)  

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот программа на языке Pascal, которая решает вашу задачу:

```pascal program CountEvenThreeDigitNumbers;

var inputNumber, countEvenThreeDigitNumbers: integer;

begin // Инициализация счетчика четных трехзначных чисел countEvenThreeDigitNumbers := 0;

// Ввод первого числа write('Введите натуральное число (для завершения введите 0): '); readln(inputNumber);

// Цикл обработки введенных чисел while inputNumber <> 0 do begin // Проверка на четность и трехзначность if (inputNumber mod 2 = 0) and (inputNumber >= 100) and (inputNumber <= 999) then // Увеличиваем счетчик четных трехзначных чисел countEvenThreeDigitNumbers := countEvenThreeDigitNumbers + 1;

// Ввод следующего числа write('Введите следующее натуральное число (для завершения введите 0): '); readln(inputNumber); end;

// Вывод результата writeln('Количество четных трехзначных чисел: ', countEvenThreeDigitNumbers); end. ```

Эта программа запрашивает у пользователя натуральные числа до тех пор, пока не будет введено число 0. После каждого ввода числа программа проверяет, является ли оно четным и трехзначным, и увеличивает счетчик, если условие выполняется. В конце программа выводит количество четных трехзначных чисел, введенных пользователем.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос