Вопрос задан 14.11.2023 в 02:36. Предмет Информатика. Спрашивает Середа Екатерина.

СРОЧНО. Напишите программу, которая в последовательности натуральных чисел определяет количество

всех чётных чисел, кратных 9. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: количество всех чётных чисел, кратных 9. Язык программирования - Питон.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Малая Ирина.

numbers_quanity = 1000

numbers_max = 30000

finalquant = 0

a = 0

for i in range(numbers_quanity):

   print("Введите число")

   a = int(input())

   if (a == 0):

       print("Количество четных чисел, кратных 9:", finalquant)

       break

   while (a < 0 or a > 30000):

       print("Введенное число не входит в диапазон от 0 до 30000, повторите ввод")

       a = int(input())

   if (a % 2 == 0 and a % 9 == 0): finalquant += 1

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке Python, которая решает задачу подсчета количества всех четных чисел, кратных 9, в последовательности натуральных чисел:

```python count = 0

while True: num = int(input("Введите число (0 для завершения): ")) if num == 0: break if num % 2 == 0 and num % 9 == 0: count += 1

print("Количество всех четных чисел, кратных 9:", count) ```

Эта программа запрашивает у пользователя последовательность натуральных чисел. Ввод чисел продолжается до тех пор, пока пользователь не введет число 0, которое служит признаком окончания ввода. После ввода чисел программа проверяет, является ли каждое число четным и кратным 9. Если число удовлетворяет этим условиям, счетчик увеличивается на 1. В конце программа выводит количество всех четных чисел, кратных 9.

Примечание: Данная программа не проверяет ограничения на количество введенных чисел (не более 1000) и на значения чисел (не более 30000). Если эти ограничения не соблюдаются, программа может работать некорректно или приводить к ошибкам.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос