Вопрос задан 14.11.2023 в 01:53. Предмет Информатика. Спрашивает Сапронова Мария.

Ввести одномерный массив A , вывести его. Проверить, имеется ли в массиве, хотя бы одна пара

соседних чисел, являющихся противоположными. Если имеется, то поменять местами первую встретившуюся такую пару. Помогите решить, мучаюсь уже часа 3, понимаю, что мне нужно получить след элемент массива, реверснуть его, сравнить с предыдущим, поменять их местами и реверснуть обратно. Я прокляну этот паскаль после того как сдам эту лабу
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Голованов Иван.

Ответ:

program qwe;

var

a:array of integer;

n,k,i:integer;

begin

writeln('Введите размерность массива: ');

readln(n);

setlength(a,n);

randomize;

k:=0;

for i:=0 to n-1 do

begin

a:=random(5)-3;

write(a,' ');

end;

writeln;

for i:=0 to n-2 do

if (a+a[i+1]=0) and (a<>0) and (a[i+1]<>0) then k:=k+1;

if (k=0) then writeln ('В массиве нет ни одной пары соседних взаимно противоположных чисел')

else writeln('В массиве соседних пар взаимно противоположных чисел - ',k,' шт');

readln;

end.

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Я могу помочь вам с вашим вопросом о программировании на Паскале.

Вы хотите написать программу, которая вводит одномерный массив A, выводит его, проверяет, имеется ли в массиве хотя бы одна пара соседних чисел, являющихся противоположными, и если имеется, то меняет местами первую встретившуюся такую пару.

Я нашел несколько ресурсов, которые могут быть полезны для вас:

- [Swapping opposite elements of a List of Integers if either is Odd](https://stackoverflow.com/questions/65968243/swapping-opposite-elements-of-a-list-of-integers-if-either-is-odd) - это вопрос и ответ на Stack Overflow, где обсуждается, как обменять элементы списка в Python, если один или оба из них нечетные. Вы можете адаптировать эту логику для вашей задачи, используя операторы сравнения и присваивания в Паскале. - [Swap elements in array to reverse an array](https://stackoverflow.com/questions/16356183/swap-elements-in-array-to-reverse-an-array) - это еще один вопрос и ответ на Stack Overflow, где показано, как обменять элементы массива в C++, чтобы развернуть его. Вы можете использовать этот пример, чтобы понять, как обменять элементы массива в Паскале, используя временную переменную. - [Write a program to reverse an array or string](https://www.geeksforgeeks.org/write-a-program-to-reverse-an-array-or-string/) - это статья на GeeksforGeeks, где объясняется, как развернуть массив или строку в разных языках программирования, включая Паскаль. Вы можете посмотреть на код Паскаля, чтобы увидеть, как работать с массивами и циклами в этом языке.

Надеюсь, эти ресурсы помогут вам решить вашу проблему. Удачи!

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос