Вопрос задан 13.11.2023 в 07:21. Предмет Информатика. Спрашивает Бухтаяров Костя.

Напишите программу, в которой вводятся три числа: a, b и с. Пускай первое число уменьшают в два

раза, а второе увеличивают на 30, третье уменьшают на 1. Выведите измененные значения переменных. НА С++
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Серебренникова Вероника.

Ответ:

вроде так, но точно не уверена!


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке C++, которая выполняет указанные операции над тремя введенными числами:

```cpp #include

int main() { int a, b, c;

std::cout << "Введите три числа: "; std::cin >> a >> b >> c;

a /= 2; b += 30; c -= 1;

std::cout << "Измененные значения переменных: " << a << ", " << b << ", " << c << std::endl;

return 0; } ```

При запуске программы она запросит у пользователя ввести три числа. Затем она выполнит указанные операции: уменьшит первое число в два раза, увеличит второе число на 30 и уменьшит третье число на 1. Наконец, программа выведет измененные значения переменных.

Например, если ввести числа 10, 20 и 30, программа выведет следующий результат:

``` Измененные значения переменных: 5, 50, 29 ```

Примечание: Предоставленный код является примером и может быть адаптирован под различные языки программирования.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос