Напишите программу для вывода массива из 100 случайных чисел. Паскаль
Ответы на вопрос
var
a:array [1..100] of integer;
i:integer;
begin
Randomize;
for i:=1 to 100 do
begin
a[i]:=random(100);
write(a[i], ', ');
end;
end.
Конечно! Вот программа на языке Pascal, которая выводит массив из 100 случайных чисел:
```pascal program RandomArray;
const ARRAY_SIZE = 100;
var arr: array[1..ARRAY_SIZE] of Integer; i: Integer;
begin Randomize;
// Заполнение массива случайными числами for i := 1 to ARRAY_SIZE do begin arr[i] := Random(100); // Используем Random для генерации случайных чисел от 0 до 99 end;
// Вывод массива for i := 1 to ARRAY_SIZE do begin WriteLn(arr[i]); end;
ReadLn; end. ```
Эта программа использует функцию `Randomize` для инициализации генератора случайных чисел, а затем заполняет массив `arr` случайными числами в диапазоне от 0 до 99 с помощью функции `Random`. Затем она выводит каждый элемент массива на экран с помощью прохода циклом `for`.
Надеюсь, эта программа вам поможет! Если у вас возникнут вопросы, не стесняйтесь задавать.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
