Напишите программу в среде программирования PascalABC. Протестируйте ее. Дан одномерный массив,
значения которого вводятся с клавиатуры. Найдите количество отрицательных элементов данного массива. На экран вывести исходный массив и полученный результат. В качестве ответа напишите код вашей программы (учитывая синтаксис языка программирования Pascal).Ответы на вопрос
program CountNegativeElements;
var
arr: array of Integer;
count, i: integer;
begin
Write('Введите размер массива: ');
Readln(count);
SetLength(arr, count);
for i := 0 to count - 1 do
begin
Write('Введите элемент массива ', i + 1, ': ');
Readln(arr[i]);
end;
Write('Исходный массив: ');
for i := 0 to count - 1 do
Write(arr[i], ' ');
Writeln;
count := 0;
for i := 0 to count - 1 do
if arr[i] < 0 then
count := count + 1;
Writeln('Количество отрицательных элементов: ', count);
Readln;
end.
Программа на языке PascalABC для подсчета количества отрицательных элементов в одномерном массиве
```pascal program CountNegativeElements;
const MAX_SIZE = 100; // Максимальный размер массива
var arr: array[1..MAX_SIZE] of real; // Одномерный массив n, i, count: integer; // Переменные для размера массива, итерации и подсчета отрицательных элементов
begin // Ввод размера массива write('Введите размер массива: '); readln(n);
// Ввод элементов массива writeln('Введите элементы массива:'); for i := 1 to n do begin write('arr[', i, '] = '); readln(arr[i]); end;
// Подсчет отрицательных элементов count := 0; for i := 1 to n do begin if arr[i] < 0 then count := count + 1; end;
// Вывод исходного массива и результата writeln('Исходный массив:'); for i := 1 to n do begin write(arr[i]:0:2, ' '); end; writeln; writeln('Количество отрицательных элементов: ', count);
end. ```
Объяснение программы
1. Программа начинается с объявления константы `MAX_SIZE`, которая определяет максимальный размер массива. В данном случае, мы установили его равным 100.
2. Затем объявляется одномерный массив `arr` типа `real` (вещественный тип данных) с размером `MAX_SIZE`.
3. Далее объявляются переменные `n`, `i` и `count`. `n` используется для хранения размера массива, `i` используется для итерации по элементам массива, а `count` используется для подсчета количества отрицательных элементов.
4. Пользователю предлагается ввести размер массива с помощью функции `readln`.
5. Затем пользователю предлагается ввести элементы массива с помощью цикла `for`. Каждый элемент вводится с помощью функции `readln` и сохраняется в соответствующем элементе массива `arr[i]`.
6. После ввода элементов массива, происходит подсчет отрицательных элементов с помощью цикла `for`. Если элемент `arr[i]` меньше нуля, то переменная `count` увеличивается на единицу.
7. Затем происходит вывод исходного массива и результата. Сначала выводится исходный массив с помощью цикла `for` и функции `write`. Затем выводится количество отрицательных элементов с помощью функции `writeln`.
Тестирование программы
Программа может быть протестирована следующим образом:
1. Введите размер массива: 5 2. Введите элементы массива: - arr = 2 - arr = -5 - arr = 0 - arr[4] = -3 - arr[5] = 1
Результат: ``` Исходный массив: 2.00 -5.00 0.00 -3.00 1.00 Количество отрицательных элементов: 2 ```
В данном случае, исходный массив содержит 5 элементов, из которых 2 элемента являются отрицательными числами.
Примечание
Обратите внимание, что в данной программе предполагается, что пользователь будет вводить только числовые значения элементов массива. Если пользователь введет некорректные данные (например, символы или строки), программа может выдать ошибку или неправильный результат. Для обработки таких ситуаций, можно добавить дополнительные проверки на корректность ввода данных.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
