Вопрос задан 09.11.2023 в 02:38. Предмет Информатика. Спрашивает Клименок Арина.

Составить программу на Паскале. В массиве хранится информация о стоимости каждой из M книг.

Определить количество самых дешевых книг(с одинаковой минимальной ценой)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кот Александр.
Var mas:array of integer;    min,kol ,j, i,n:integer;
begin
Randomize; min:=0;kol:=0;
write('n:' );
readln(n);   
setlength(mas,length(mas)+n);///динамический массив вы можете заменить на статический 
 For i:= 0 to high(mas) do 
  mas[i]:=Random(50);   
min:=mas[0]; 
 for j:=0 to high(mas) do//ищем минимальную ценну 
 if min>mas[j] then 
 min:=mas[j] ; 
 For i:= 0 to high(mas) do 
 if min=mas[i] then//ищем количество книг с минимальной ценой
   inc(kol);   
write('kolvo min  ',kol); 
 readln;
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на языке Паскаль для определения количества самых дешевых книг с одинаковой минимальной ценой может выглядеть следующим образом:

```pascal program CountCheapestBooks;

const M = 10; // Количество книг в массиве

var books: array[1..M] of Integer; // Массив с информацией о стоимости каждой книги minPrice: Integer; // Минимальная цена книги count: Integer; // Количество самых дешевых книг

begin // Заполнение массива с информацией о стоимости каждой книги books[1] := 50; books[2] := 30; books[3] := 40; books[4] := 30; books[5] := 20; books[6] := 50; books[7] := 30; books[8] := 20; books[9] := 40; books[10] := 20;

// Нахождение минимальной цены книги minPrice := books[1]; for var i := 2 to M do begin if books[i] < minPrice then minPrice := books[i]; end;

// Подсчет количества самых дешевых книг count := 0; for var i := 1 to M do begin if books[i] = minPrice then count := count + 1; end;

// Вывод результата writeln('Количество самых дешевых книг: ', count); end. ```

В данной программе мы используем массив `books`, в котором хранится информация о стоимости каждой из M книг. Затем мы находим минимальную цену книги, перебирая все элементы массива. После этого мы подсчитываем количество книг с минимальной ценой и выводим результат.

Примечание: В данном примере мы предполагаем, что стоимость каждой книги хранится в массиве `books`. Вы можете изменить значения в массиве `books` в соответствии с вашими данными.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос