Вопрос задан 29.07.2018 в 03:17. Предмет Информатика. Спрашивает Ориняк Арина.

Составьте программу нахождения наибольшего общего делителя трёх чисел, используя следующую формулу:

НОД(А,В,С)=НОД(НОД(А,В),С). (По примеру на фото)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Неведомская Елизавета.
Function NOD(A, B: integer): integer;
  begin
    while (A <> 0) and (B <> 0) do
      if A >= B then
        A := A mod B
      else
        B := B mod A;
    Result := A + B;
  end;
 var
    A, B, C: integer; begin
    write(tri chisla:');
    readln(A,B,C); 
    writeln(NOD(A,NOD(B,C))); 
    readln; 
end.
Не забудь поставить лучший ответ
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос