Программа Паскаль. Напишите программу, которая вводит трехзначное целое число и выводит ответ
'да', если все цифры в его записи расположены в порядке возрастания.Ответы на вопрос
var n,s,d,e:integer;
begin
writeln('Введите трёхзначное число');
readln(n);
s:=n div 100;
d:=n div 10 mod 10;
e:=n mod 10;
if (s<d) and (d<e) then
writeln('да')
else
writeln('нет');
end.
Программа на Паскаль будет выглядеть следующим образом:
```pascal program CheckAscendingOrder;
var number, digit1, digit2, digit3: integer; ascending: boolean;
begin // Ввод трехзначного числа write('Введите трехзначное число: '); readln(number);
// Получение цифр числа digit1 := number div 100; digit2 := (number div 10) mod 10; digit3 := number mod 10;
// Проверка на возрастание ascending := (digit1 < digit2) and (digit2 < digit3);
// Вывод результата if ascending then writeln('Да') else writeln('Нет'); end. ```
Представленная программа сначала считывает трехзначное число с помощью `readln`, после чего разбивает его на отдельные цифры с помощью деления и остатка от деления. Затем программа выполняет проверку на возрастание с помощью оператора `and` и выводит результат "Да" или "Нет" в зависимости от значения переменной `ascending`.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
