Составить программу вычисления произведения целых чисел, кратных 3, в интервале от 30 до 150. На
C++.Ответы на вопрос
Ответ:
#include <iostream>
using namespace std;
int main()
{
long a = 1;
for (int i = 30;i<=150;i++){
if(i % 3 == 0)
a = a*i;
}
std::cout << a << std::endl;
return 0;
}
Программа на языке C++ для вычисления произведения целых чисел, кратных 3, в интервале от 30 до 150 может выглядеть следующим образом:
```c++
#include
int main() { int product = 1; for (int i = 30; i <= 150; i++) { if (i % 3 == 0) { product *= i; } } std::cout << "Произведение целых чисел, кратных 3, в интервале от 30 до 150: " << product << std::endl; return 0; } ```
В данной программе мы используем цикл `for` для последовательного перебора всех чисел от 30 до 150. Затем проверяем, является ли текущее число кратным 3, с помощью оператора `%` (остаток от деления). Если число кратно 3, умножаем его на текущее значение переменной `product`.
В конце программы выводим полученное произведение с помощью функции `std::cout` из библиотеки `iostream`.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
