Вопрос задан 05.11.2023 в 16:00. Предмет Информатика. Спрашивает Куанова Аида.

Задание 2: Составь программу.Спортсмен-лыжник начал тренировки, пробежав в первый день 10 км.

Каждый следующий день он увеличивал длину пробега на К км больше чем в предыдущий день (К –целое число, 0 < К < 100). Необходимо определить, после какого дня общий суммарный пробег лыжника за все дни превысит М км (М –целое число, 0 < М < 100). Подсказка: Вывести найденное количество дней K.Пример: если К=5, М=50, ответ: 8 дней Пожалуйста прошу помогите на языке python​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Баранчиков Василий.

Ответ:

k, m = map(int, input().split())

day_km = 10

S_total = 10

day = 1

while m > S_total:

 day_km += k

 S_total += day_km

 day += 1

print(day)

Не знаю откуда у вас это задание, но пример в нем явно неправильный. Если мы вводим k = 5 и m = 50, то за первый день он проходит 10 км, за второй еще 15, за третий еще 20 и за четвертый 25, в итоге за 4 дня он пройдет 70 км что больше 50. Значит правильный ответ на этот пример не 8, а 4

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения данной задачи можно написать программу на языке Python. Вам нужно будет вводить значения K (увеличение длины пробега в км) и M (целевой суммарный пробег в км), а программа будет выводить количество дней, через которое общий суммарный пробег лыжника превысит M.

Вот пример Python-программы для решения этой задачи:

```python # Ввод значений K и M K = int(input("Введите K (увеличение длины пробега в км): ")) M = int(input("Введите M (целевой суммарный пробег в км): "))

# Инициализируем переменные для отслеживания текущего дня и суммарного пробега current_day = 1 total_distance = 10 # Пробег в первый день

# Пока суммарный пробег меньше или равен M, увеличиваем длину пробега while total_distance <= M: current_day += 1 total_distance += 10 + (current_day - 1) * K

# Выводим найденное количество дней print("После", current_day, "дней общий суммарный пробег превысит", M, "км.") ```

Эта программа сначала запрашивает значения K и M у пользователя, затем использует цикл while, чтобы увеличивать суммарный пробег лыжника, пока он не превысит целевой M. Когда цель достигнута, программа выводит количество дней, которое потребовалось для достижения цели.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос