Вопрос задан 05.11.2023 в 01:08. Предмет Информатика. Спрашивает Мальцев Денис.

Программирование алгоритмов обработки одномерных массивов. Выполнить программу на С++ Задан

массив состоящий из нулей и единиц проверьте существует ли их строгое чередование.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Толысбекова Балнура.

Ответ:

Потное задание

#include <stdio.h>

#include <stdlib.h>

#include <time.h>

 

/*

*

*  Сформировать массив из N элементов (N<50) , которыми могут быть только целые числа 0 и 1.  

*  Проверить, существует ли строгое чередование 0 и 1.

*

*/

 

#define ARR_SIZE 10

 

int main(void){

   int arr[ARR_SIZE], i;

   

   srand(time(NULL));

   

   printf("\nArray: ");

   for ( i = 0; i < ARR_SIZE; ++i )

       printf("%d ", (arr[i] = rand() % 2));

   

   for ( i = 1; i < ARR_SIZE && arr[i] != arr[i-1]; ++i )

       ;

   printf("\nIs %s\n", ( i == ARR_SIZE ) ? "good" : "bad");

   

   return 0;

}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, давайте рассмотрим, как можно написать программу на C для проверки строгого чередования нулей и единиц в массиве. Для простоты предположим, что массив представлен в виде целочисленного массива. Ваш запрос немного абстрактен, поэтому предположим, что мы хотим проверить чередование элементов вида 0101... или 1010...

Вот пример программы на C:

```c #include

// Функция для проверки строгого чередования нулей и единиц int checkAlternation(int arr[], int size) { for (int i = 0; i < size - 1; i++) { // Если два соседних элемента равны, значит, чередование нарушено if (arr[i] == arr[i + 1]) { return 0; // Чередование нарушено } } return 1; // Чередование существует }

int main() { // Заданный массив int arr[] = {0, 1, 0, 1, 0, 1}; int size = sizeof(arr) / sizeof(arr[0]);

// Проверяем чередование if (checkAlternation(arr, size)) { printf("Чередование существует.\n"); } else { printf("Чередование не существует.\n"); }

return 0; } ```

Эта программа определяет функцию `checkAlternation`, которая принимает массив и его размер в качестве аргументов и возвращает 1, если чередование существует, и 0 в противном случае. Функция `main` создает массив, вызывает `checkAlternation` и выводит соответствующее сообщение.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос