Вопрос задан 04.11.2023 в 18:54. Предмет Информатика. Спрашивает Вагнер Даня.

1) напишите программу для нахождения суммы чисел от 10 до 20. 2) напишите программу для нахождения

произведения чисел от 1 до числа n (введите число 5 и отдельно 10). ​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Киладзе Майя.

#-------1-----

summa = 0

for i in range(10,20):

   summa += i

print(summa)

#---------2-----------

proiz = 1

for i in range(1, int(input("n: "))):

   proiz *= i

print(proiz)


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этих задач на Python, вы можете использовать циклы for и встроенные функции sum() и reduce().

1) Для нахождения суммы чисел от 10 до 20, вы можете использовать цикл for и функцию range(). Вот пример кода:

```python sum = 0 for i in range(10, 21): sum += i print(sum) ```

В этом коде, цикл for проходит по каждому числу в диапазоне от 10 до 20 (включительно). Каждое число добавляется к переменной sum, которая в конце содержит сумму всех чисел в этом диапазоне.

2) Для нахождения произведения чисел от 1 до n, вы можете использовать функцию reduce() из модуля functools и генератор чисел. Вот пример кода:

```python from functools import reduce import operator

n = 5 product = reduce(operator.mul, range(1, n+1)) print(product) ```

В этом коде, функция reduce() применяет функцию mul (произведение) к каждому числу в диапазоне от 1 до n (включительно). Результат - произведение всех чисел в этом диапазоне.

Для числа 10, код будет выглядеть так:

```python n = 10 product = reduce(operator.mul, range(1, n+1)) print(product) ```

Обратите внимание, что в Python диапазон чисел включает в себя левую границу, но не включает правую. Поэтому, чтобы включить в диапазон число 20 или 10, нужно указать в функции range() число 21 и 11 соответственно.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос