Вопрос задан 04.11.2023 в 16:03. Предмет Информатика. Спрашивает Garifullin Karim.

Составьте программу которая выводит на четные числа от 8 до 40​

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Арефьев Александр.

for i in range(8,41,2):

   print(i,end=" ")

0 0
Отвечает Спирякова Галечка.

Pascal ABC:

var  i: longint;

begin  for i := 8 to 40 do  

begin    

if(i mod 2 = 0) then write(i, ' ')  end;

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Чтобы вывести все четные числа в диапазоне от 8 до 40, вы можете использовать цикл `for` в Python. Цикл `for` позволяет итерировать по последовательности (в данном случае, по диапазону чисел), и для каждого элемента в этой последовательности выполнять определенный код. В нашем случае, код будет проверять, является ли число четным, и если это так, то выводить его на экран.

Вот пример кода, который решает вашу задачу:

```python for i in range(8, 41): if i % 2 == 0: print(i) ```

В этом коде:

- `range(8, 41)` создает последовательность чисел от 8 до 40. Обратите внимание, что верхний предел в функции `range` является исключительным, поэтому мы используем 41, чтобы включить число 40 в диапазон. - `for i in range(8, 41):` начинает цикл, в котором переменная `i` принимает значение каждого числа в последовательности. - `if i % 2 == 0:` проверяет, является ли число `i` четным. Если число делится на 2 без остатка (т.е. остаток от деления `i` на 2 равен 0), то это значит, что число `i` является четным. - `print(i)` выводит число `i` на экран, если оно является четным.

Таким образом, этот код будет выводить все четные числа в диапазоне от 8 до 40 .

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос