Вопрос задан 04.11.2023 в 09:03. Предмет Информатика. Спрашивает Подмазов Женя.

Даны два целых числа m и n.Напишите программу , которая выводит все числа от m до n включительно в

порядке возрастания ,если m больше n,или в порядке убывания,в противном случae Паскаль​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Котов Дмитрий.

m = int(input())

n = int(input())

if n < m:

   for i in range(m, n + 1):

       print(i)

else:

   for i in range(m, n - 1, -1):

       print(i)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Решение на языке Pascal

```pascal program PrintNumbers; var m, n, i: integer; begin readln(m, n); if m > n then begin for i := m downto n do writeln(i); end else begin for i := m to n do writeln(i); end; end. ```

Программа считывает два целых числа `m` и `n` и выводит все числа от `m` до `n` включительно в порядке возрастания, если `m` больше `n`, или в порядке убывания в противном случае.

Пример работы программы

Входные данные: ``` 20 15 ```

Выходные данные: ``` 20 19 18 17 16 15 ```

Если входные данные будут `15 20`, то программа выведет числа от 15 до 20 в порядке возрастания.

Объяснение решения

Программа считывает два целых числа `m` и `n` с помощью функции `readln`. Затем она проверяет, является ли `m` больше `n`. Если это так, то программа использует цикл `for` для вывода чисел от `m` до `n` в порядке убывания. Если `m` не больше `n`, то программа использует цикл `for` для вывода чисел от `m` до `n` в порядке возрастания.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос