Составить программу : Ввести три числа, найти их сумму, произведение и среднее арифметическое.
Пример: Введите три числа: 4 5 7 4+5+7=16 4*5*7=140 (4+5+7)/3=5.333333Ответы на вопрос
/* Си */
#include <stdio.h>
int main()
{
int n = 3, temp;
int sum = 0;
int mult = 1;
printf("Введите три числа:\n");
for (int i = 0; i < n; i++)
{
scanf("%d", &temp);
sum += temp;
mult *= temp;
}
printf("сумма: %d\n", sym);
printf("произведение: %d\n", mult);
printf("среднее арифметическое: %d\n", sum / n);
return 0;
}
Для решения этой задачи на языке Python, вам потребуется использовать функцию `input()` для получения ввода от пользователя, а затем выполнить необходимые вычисления.
Вот базовый шаблон программы, который выполняет эту задачу:
```python # Ввод трех чисел a = float(input("Введите первое число: ")) b = float(input("Введите второе число: ")) c = float(input("Введите третье число: "))
# Вычисление суммы sum = a + b + c
# Вычисление произведения product = a * b * c
# Вычисление среднего арифметического average = (a + b + c) / 3
# Вывод результатов print("Сумма: ", sum) print("Произведение: ", product) print("Среднее арифметическое: ", average) ```
В этом коде `input()` используется для получения чисел от пользователя. Функция `input()` возвращает строку, поэтому мы используем функцию `float()` для преобразования строки в число с плавающей точкой.
Затем мы вычисляем сумму, произведение и среднее арифметическое введенных чисел. Наконец, мы выводим результаты с помощью функции `print()`.
Обратите внимание, что в этом коде нет проверки на корректность ввода пользователя. Если пользователь введет что-то, что не может быть преобразовано в число, программа выдаст ошибку. В реальной программе вам, возможно, потребуется добавить проверки на ввод пользователя.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
