Вопрос задан 03.11.2023 в 12:50. Предмет Информатика. Спрашивает Пиджакова Лера.

Напишите программу в Питоне. Введите с клавиатуры 8 положительных целых чисел. Определите,

сколько из них делятся на 3 и при этом заканчиваются на 4. Программа должни вывести одно число: количество чисел, кратных 3 и оканчивающихся на 4.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Айдар Анель.

Ответ:

Объяснение:

inputStr = input().split()

result = 0

for i in range(0,8):

   if (inputStr[i][-1] == '4') and (int(inputStr[i]) % 3 == 0):

       result+= 1

print(result)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот программа на Python, которая выполняет задачу:

```python # Создаем переменную для хранения количества чисел, которые соответствуют условиям count = 0

# Считываем 8 чисел с клавиатуры for i in range(8): num = int(input("Введите положительное целое число: ")) # Проверяем, соответствует ли число условиям (делится на 3 и оканчивается на 4) if num > 0 and num % 3 == 0 and num % 10 == 4: count += 1

# Выводим результат print("Количество чисел, кратных 3 и оканчивающихся на 4:", count) ```

Эта программа сначала считывает 8 целых чисел с клавиатуры в цикле. Затем она проверяет каждое из введенных чисел на соответствие двум условиям: оно должно быть положительным, делиться на 3 и оканчиваться на 4. Если число соответствует этим условиям, то увеличивается счетчик `count`. По завершении цикла программа выводит количество чисел, удовлетворяющих условиям.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос