Вопрос задан 03.11.2023 в 08:33. Предмет Информатика. Спрашивает Сарсентаева Нурсулу.

Надо написать программу для решения этой задачи. На языке Python 3.7.2Дана последовательность из

n (1≤n≤105) чисел ai (1≤ai≤1012) и q запросов (1≤q≤105). Каждый запрос предстает собой число pi (1≤pi≤1012).Задача состоит в том, чтобы на каждый запрос вывести ответ - входит ли pi в исходную последовательность.Входные данныеВ первой строчке задается число n (1≤n≤105) и количество запросов q (1≤q≤105). Далее идут n чисел ai (1≤ai≤1012). Далее записаны q запросов pi (1≤pi≤1012).Выходные данныеВывести q ответов на запросы: на i-й запрос вывести ответ - «Yes», если pi содержится в исходной последовательности и «No» в остальных случаях)Примервходные данныеСкопировать8 51 2 4 9 7 2 3 81103811выходные данныеСкопироватьYesNoYesYesNo
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Парапетов Карл.

Ответ:

n=int(input("Введите число n: "))

while n < 1 and n > 105:

   n=int(input("Введите число n: "))

q=int(input("Введите число q: "))

while q < 1 and q > 105:

   q=int(input("Введите число q: "))

check='No'

a=[0]*n

for i in range(n):

   a[i]=int(input())

b=[0]*q

for j in range(q):

   b[j]=int(input())

for x in range(q):

   for y in range(n):

       if b[x]==a[y]:

           check='Yes'

           break

       else:

           check='No'

   print(check)

Объяснение:

Табуляцию сохраняем

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на языке Python для решения данной задачи может выглядеть следующим образом:

```python n, q = map(int, input().split()) # считываем число n и количество запросов q

sequence = set(map(int, input().split())) # считываем исходную последовательность чисел

for _ in range(q): query = int(input()) # считываем очередной запрос

if query in sequence: print("yes") # если число содержится в последовательности, выводим "yes" else: print("no") # если число не содержится в последовательности, выводим "no" ```

В данной программе мы сначала считываем число `n` и количество запросов `q`. Затем принимаем последовательность чисел и преобразуем ее в множество, чтобы ускорить проверку наличия числа в последовательности.

Затем мы выполняем цикл `for` чтобы обработать все запросы. Для каждого запроса мы считываем число `query` и проверяем его наличие в исходной последовательности. Если число содержится в последовательности, мы выводим "yes", иначе - "no".

Пример использования программы:

``` Входные данные: 8 5 1 2 4 9 7 2 3 8 1 3 5 6 8

Выходные данные: yes yes no no yes ```

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос