
1 вопрос Написать программу на языке паскаль которая вычисляет стоимость покупки в магазине. Для
определения будем считать, что в покупной набор входят апельсины и яблоки. С клавиатуры вводится:стоимость 1 кг апельсинов;стоимость 1 кг яблок ;вес апельнов и вес яблок.2вопрос Даны длина рёбер a, b, c прямоугольного паралепипида. Найти его объём V=ABC и площадь поверхности S= 2(ab+bc+ac)

Ответы на вопрос

var
a1,a2,b1,b2:integer;
begin
write('Цена за 1кг апельсинов: '); readln(a1);
write('Цена за 1кг яблок: '); readln(b1);
write('Вес апельсинов: '); readln(a2);
write('Вес яблок: '); readln(b2);
writeln('Общая цена: ',a1*a2+b1*b2);
end.
var
a,b,c:integer;
begin
readln(a,b,c);
writeln('V= ', a*b*c);
writeln('S= ',2*(a*b+b*c+a*c));
end.



Программа на языке Паскаль для вычисления стоимости покупки в магазине:
```pascal program purchase_cost;
var costOranges, costApples, weightOranges, weightApples, totalCost: real;
begin // Ввод данных с клавиатуры writeln('Введите стоимость 1 кг апельсинов:'); readln(costOranges); writeln('Введите стоимость 1 кг яблок:'); readln(costApples); writeln('Введите вес апельсинов в кг:'); readln(weightOranges); writeln('Введите вес яблок в кг:'); readln(weightApples); // Вычисление стоимости покупки totalCost := costOranges * weightOranges + costApples * weightApples; // Вывод результата writeln('Стоимость покупки:', totalCost:0:2); end. ```
Программа на языке Паскаль для вычисления объема и площади поверхности прямоугольного параллелепипеда:
```pascal program rectangular_prism;
var a, b, c, volume, surfaceArea: real;
begin // Ввод данных с клавиатуры writeln('Введите длину ребра a:'); readln(a); writeln('Введите длину ребра b:'); readln(b); writeln('Введите длину ребра c:'); readln(c); // Вычисление объема volume := a * b * c; // Вычисление площади поверхности surfaceArea := 2 * (a * b + b * c + a * c); // Вывод результата writeln('Объем параллелепипеда:', volume:0:2); writeln('Площадь поверхности параллелепипеда:', surfaceArea:0:2); end. ```
Оба этих программы считывают необходимые данные с клавиатуры, вычисляют результат и выводят его на экран. Программы могут быть скомпилированы и запущены на любой совместимой с языком Паскаль среде разработки.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili