Вопрос задан 02.11.2023 в 00:23. Предмет Информатика. Спрашивает Поморов Захар.

1) Задача1: Напишите программу, которая считывает рост и вес претендентов в команду по плаванию до

тех пор, пока не будет введено слово «стоп». Программа должна вывести количество подходящих кандидатур (рост > 175, вес < 80). ПАЙТОН
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Шматков Данил.

Ответ:

Const n=50;  

Var  

a:array [1..n] of integer;  

i,k:integer;  

Begin  

Writeln('Рост всех претендентов:');  

Randomize;  

k:=0;

for i:=1 to n do  

begin  

a[i]:=Random(51)+150;  

Write(a[i],' ');  

if a[i]>=170 then k:=k+1;  

end;  

Writeln;  

Writeln('Количество имеющих шанс: ',k);  

End.

Объяснение:

0 0
Отвечает Клинских Полина.

Ответ:

#by MurziK

cand = {}

while True:

    name = str(input())

    rost = int(input())

    ves = int(input())

    if name == 'стоп':

         break

         print(cand)

    elif rost > 175 and ves < 80:

         cand.append(name)

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке Python, которая решает данную задачу:

```python count = 0 # счетчик подходящих кандидатур

while True: input_data = input("Введите рост и вес претендента (через пробел) или введите 'стоп' для завершения: ")

if input_data == "стоп": break

# разбиваем строку на рост и вес height, weight = map(int, input_data.split())

# проверяем условие подходящей кандидатуры if height > 175 and weight < 80: count += 1

print("Количество подходящих кандидатур:", count) ```

Программа работает следующим образом: 1. Инициализируется переменная `count` для хранения количества подходящих кандидатур. 2. Запускается бесконечный цикл `while True`. 3. Внутри цикла пользователю предлагается ввести данные (рост и вес претендента), либо ввести слово "стоп" для завершения программы. 4. Если пользователь ввел "стоп", то выполнение программы прерывается с помощью оператора `break`. 5. Если пользователь ввел данные, то строка разбивается на рост и вес с помощью функции `split()`. 6. Затем проверяется условие подходящей кандидатуры (рост > 175 и вес < 80). 7. Если условие выполняется, то счетчик `count` увеличивается на 1. 8. После окончания работы цикла выводится количество подходящих кандидатур.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос