Составить программы для следующих задач (сохранить в Паскале либо код скопировать в документ Word):
№1. Вводится натуральное число N. Вывести все целые числа от N до 1. Пример: Входные данные: 5 Выходные данные: 5 4 3 2 1 №1. Вводятся два целых числа A и B. Вывести все нечетные числа от A до B, включая A и B. Пример: Входные данные: 3 10 Выходные данные: 3 5 7 9 №2. Вводятся два целых числа A и B. Вывести сумму всех чисел от A до B, включая A и B, которые заканчиваются на 7. Пример: Входные данные: 5 30 Выходные данные: 51 (Пояснение: 7+17+27 = 51)Ответы на вопрос
Ответ:
Если не знаешь, как это делается, подсказываю: открываешь исходник Блокнотом, нажимаешь Ctrl+A (лат) , выделяется весь текст, нажимаешь Ctrl+Insert, весь выделенный текст копируется в буфер, открываешь документ в Ворде и нажимаешь Shift+Insert. Текст из буфера копируется на лист в Ворде.
А вот исходник открывать прямо в Ворде не советую - если чего испортишь случайно, потом он в Паскале не откроется.
Ответ:
Составить программУ для следующих задач
Объяснение:

Программа для задачи №1:
```pascal program Task1; var n, i: integer; begin write('Введите натуральное число: '); readln(n); write('Искомая последовательность чисел: '); for i := n downto 1 do write(i, ' '); end. ```
Программа для задачи №2:
```pascal program Task2; var a, b, i: integer; begin write('Введите первое целое число: '); readln(a); write('Введите второе целое число: '); readln(b); write('Искомая последовательность нечетных чисел: '); for i := a to b do begin if (i mod 2 <> 0) then write(i, ' '); end; end. ```
Программа для задачи №3:
```pascal program Task3; var a, b, i, sum: integer; begin write('Введите первое целое число: '); readln(a); write('Введите второе целое число: '); readln(b); sum := 0; write('Сумма чисел, заканчивающихся на 7: '); for i := a to b do begin if (i mod 10 = 7) then begin sum := sum + i; write(i, ' '); end; end; writeln(); writeln('Сумма всех чисел: ', sum); end. ```
Не забудьте сохранить каждую программу в отдельном файле с расширением ".pas", а затем скопировать содержимое каждого файла в документ Word.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
