
Вопрос задан 10.07.2023 в 16:59.
Предмет Информатика.
Спрашивает Ладыгина Анастасия.
Составить программы для задач (в Паскале) 1) Вводится натуральное число N. Вывести все целые
числа от N до 1. Пример: Входные данные: 5 Выходные данные: 5 4 3 2 1 2) Вводятся два целых числа A и B. Вывести все нечётные числа от A до B, включая A и B. Пример: Входные данные: 3 10 Выходные данные: 3 5 7 9 3) Вводятся два целых числа A и B. Вывести сумму всех чисел от A до B, включая A и B, которые заканчиваются на 7. Пример: Входные данные: 5 30 Выходные данные: 51 (Пояснение: 7+17+27=51) Хелп ми

Ответы на вопрос

Отвечает Наумчик Карина.
я не думаю что это так но я это понимаю вот так -




Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот программы для решения каждой из задач на языке Pascal:
- Вывод всех целых чисел от N до 1:
pascalprogram PrintNumbers; var N, i: integer; begin writeln('Введите натуральное число N:'); readln(N); writeln('Целые числа от ', N, ' до 1:'); for i := N downto 1 do writeln(i); end.
- Вывод всех нечётных чисел от A до B:
pascalprogram PrintOddNumbers; var A, B, i: integer; begin writeln('Введите два целых числа A и B:'); readln(A, B); writeln('Нечётные числа от ', A, ' до ', B, ':'); for i := A to B do begin if i mod 2 <> 0 then writeln(i); end; end.
- Вывод суммы чисел от A до B, заканчивающихся на 7:
pascalprogram SumNumbers; var A, B, i, sum: integer; begin writeln('Введите два целых числа A и B:'); readln(A, B); sum := 0; writeln('Сумма чисел от ', A, ' до ', B, ', заканчивающихся на 7:'); for i := A to B do begin if i mod 10 = 7 then sum := sum + i; end; writeln(sum); end.
Надеюсь, это поможет вам! Если у вас возникнут дополнительные вопросы, не стесняйтесь задавать.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili