
Помогите написать программу на языке C++ с помощью процедур Void... Напишите процедуру, которая
принимает параметр – натуральное число N – и выводит на экран линию из N символов '–'. Введите N: ---------- Буду благодарен.

Ответы на вопрос

#include<iostream>
using namespace std;
void show(int N)
{
for (int i = 0; i < N; i++)
cout << "-";
cout << endl;
}
void main()
{
setlocale(LC_ALL, "rus");
int N;
cout << "Введите N: ";
cin >> N;
show(N);
system("pause");
}



Конечно, я помогу вам написать программу на C++ с использованием процедур. Ваша задача - написать процедуру, которая принимает натуральное число N и выводит на экран линию из N символов '-'.
Вот пример программы:
```cpp
#include
void printLine(int N) { for(int i = 0; i < N; i++) { cout << '-'; } cout << endl; }
int main() { int N; cout << "Введите N: "; cin >> N;
if(N > 0) { printLine(N); } else { cout << "N должно быть натуральным числом." << endl; }
return 0; } ```
Обратите внимание, что здесь есть функция `printLine`, которая принимает параметр `N` и выводит на экран `N` символов '-'. В функции `main` сначала запрашивается значение `N`, а затем проверяется, что оно больше нуля. Если `N` не натуральное число, программа выведет сообщение об ошибке.
Теперь вы можете скомпилировать и запустить эту программу. Она запросит у вас значение `N` и выведет соответствующую линию из символов '-'.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili