C# Напишите программу, которая вычисляет сумму элементов матрицы.Входные данныеВ первой строке
записаны через пробел размеры матрицы: количество строк N и количество столбцов M ( 1 ≤ N , M ≤ 100 ). В следующих N строках записаны строки матрицы, в каждой – по M натуральных чисел, разделённых пробелами.Выходные данныеПрограмма должна вывести одно число – сумму элементов матрицы.Примерывходные данные4 51 2 3 4 56 12 8 9 1011 12 12 14 1516 17 18 12 20выходные данные207Программа на C#Ответы на вопрос
Ответ:
using System;
namespace ConsoleApp18
{
class Program
{
static void Main(string[] args)
{
string s = Console.ReadLine();
int n = int.Parse(s.Split(' ')[0]), m = int.Parse(s.Split(' ')[1]), sum = 0;
int[,] a = new int[n,m];
for (int i = 0; i < n; i++)
{
s = Console.ReadLine();
for (int j = 0; j < m; j++)
{
a[i, j] = int.Parse(s.Split(' ')[j]);
sum += a[i, j];
}
}
Console.WriteLine(sum);
Console.ReadKey();
}
}
}
Объяснение:
Для решения данной задачи на C# можно использовать следующий код:
```csharp using System;
class Program { static void Main(string[] args) { // Чтение размеров матрицы string[] sizes = Console.ReadLine().Split(); int n = int.Parse(sizes[0]); int m = int.Parse(sizes[1]);
// Создание матрицы int[,] matrix = new int[n, m];
// Чтение элементов матрицы for (int i = 0; i < n; i++) { string[] row = Console.ReadLine().Split(); for (int j = 0; j < m; j++) { matrix[i, j] = int.Parse(row[j]); } }
// Вычисление суммы элементов матрицы int sum = 0; for (int i = 0; i < n; i++) { for (int j = 0; j < m; j++) { sum += matrix[i, j]; } }
// Вывод результата Console.WriteLine(sum); } } ```
Программа сначала считывает размеры матрицы из первой строки входных данных. Затем создает двумерный массив с заданными размерами. Далее происходит чтение элементов матрицы из следующих N строк входных данных. Затем происходит вычисление суммы элементов матрицы с помощью двух вложенных циклов. Результат выводится на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
