
На С++ Напишите программу, которая вычисляет сумму элементов матрицы. Входные данные В первой
строке записаны через пробел размеры матрицы: количество строк N и количество столбцов M ( 1 ≤ N , M ≤ 100 ). В следующих N строках записаны строки матрицы, в каждой – по M натуральных чисел, разделённых пробелами. Выходные данные Программа должна вывести одно число – сумму элементов матрицы. Примеры входные данные 4 5 1 2 3 4 5 6 12 8 9 10 11 12 12 14 15 16 17 18 12 20 выходные данные 207

Ответы на вопрос

#include <iostream>
#include <vector>
using namespace std;
int main()
{
size_t N, M, sum{ 0 };
cin >> N >> M;
vector<vector<int>> v(N, vector<int>(M));
for (size_t i = 0; i < N; ++i) {
for (size_t j = 0; j < M; ++j) {
cin >> v[i][j];
sum += v[i][j];
cout << v[i][j] << " ";
}
cout << endl;
}
cout << sum << endl;
}



Программа для вычисления суммы элементов матрицы
Для решения этой задачи можно написать программу на языке C++. Вот пример программы:
```cpp
#include
int main() { int N, M; cin >> N >> M; // Ввод размеров матрицы
int matrix[N][M]; // Объявление матрицы размера N x M
// Ввод элементов матрицы for (int i = 0; i < N; i++) { for (int j = 0; j < M; j++) { cin >> matrix[i][j]; } }
int sum = 0; // Переменная для хранения суммы элементов матрицы
// Вычисление суммы элементов матрицы for (int i = 0; i < N; i++) { for (int j = 0; j < M; j++) { sum += matrix[i][j]; } }
cout << sum; // Вывод суммы элементов матрицы
return 0; } ```
Эта программа сначала считывает размеры матрицы N и M, затем считывает элементы матрицы, вычисляет их сумму и выводит результат.
Пример входных данных: ``` 4 5 1 2 3 4 5 6 12 8 9 10 11 12 12 14 15 16 17 18 12 20 ```
Выходные данные: ``` 207 ```
Этот пример демонстрирует ввод матрицы размера 4x5 и вычисление суммы её элементов, которая равна 207.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili