Вопрос задан 01.11.2023 в 09:50. Предмет Информатика. Спрашивает Синелобов Саша.

Помогите , пожалуйста , написать программу по информатике (можно на Pascal или на C++)!

Количество минимумовНайдите количество минимальных элементов в последовательности.Входные данныеВводится натуральное число N, а затем N чисел.Выходные данныеВыведите количество минимальных элементов.Например :Мы вводим :3 21114На выходе получаем : 1​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Матусевич Таня.

#include <iostream>

using namespace std;

void main(){

int N, a, min, cmin;

cin >> N;

cin >> min;

cmin = 1;

for(int i=1; i<N;i++){

cin >> a;

if(min==a)

cmin++;

if(min>a){

min = a;

cmin = 1;

}

}

cout << cmin;

}

0 0
Отвечает Козина Мария.

Ответ:

PascalABC.NET (Обязательно .NET, используется библиотека классов .NET)

begin

 var list: List<integer> := new List<integer>;

 var N := ReadInteger();

 for var i := 1 to N do

 begin

   list.Add(ReadInteger());

 end;

 

 list.Where(x -> x = list.Min()).Count.Println();

end.

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам написать программу для поиска количества минимальных элементов в последовательности на языке программирования Pascal. Вот пример такой программы:

```pascal program CountMinElements; var N, num, minValue, count, i: integer; begin // Инициализируем счетчик минимальных элементов count := 0;

// Вводим количество элементов в последовательности write('Введите количество элементов (N): '); readln(N);

if N < 1 then begin writeln('Количество элементов должно быть больше 0.'); exit; end;

// Вводим первый элемент и считаем его минимальным write('Введите элемент 1: '); readln(minValue);

for i := 2 to N do begin // Вводим следующий элемент write('Введите элемент ', i, ': '); readln(num);

if num < minValue then begin // Если новый элемент меньше текущего минимального, обновляем минимальное значение и сбрасываем счетчик minValue := num; count := 1; end else if num = minValue then begin // Если новый элемент равен текущему минимальному, увеличиваем счетчик count := count + 1; end; end;

writeln('Количество минимальных элементов: ', count); end. ```

Эта программа сначала запрашивает у вас количество элементов в последовательности (N) и первый элемент. Затем она сравнивает каждый следующий элемент с текущим минимальным элементом. Если он меньше, она обновляет минимальное значение и сбрасывает счетчик. Если элемент равен текущему минимальному, она увеличивает счетчик. После обработки всех элементов, программа выводит количество минимальных элементов.

Вы можете скомпилировать и запустить эту программу в среде, поддерживающей язык Pascal, чтобы проверить её работу.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос